View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003513VTK(No Category)public2006-07-15 01:472011-01-13 17:01
ReporterAndrew Maclean 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003513: Examples will not build when using QT4
DescriptionBuilding VTK with build examples on fails with the message:
/usr/bin/uic3-qt4: no such file or directory.
Google search on "uic3-qt4" returns nothing.

My machine is is running Debian etch with QT4.1.3-3 installed.
/usr/bin/uc, /usr/bin/uic3 and /usr/bin/uic-qt4 are present.
TagsNo tags attached.
Project
Type
Attached Files

 Relationships

  Notes
(0004663)
Tim Peeters (reporter)
2006-08-17 13:04

The same problem occurs with Ubuntu Linux 6.06.
(0004726)
Andrew Maclean (reporter)
2006-08-23 21:37

CLinton, I think you did a lot of QT work. If not could you please reassign this one to the appropriate person.

Anyway, the problem is related to the fact that there is no such file as /usr/bin/uic3-qt4 but there is /usr/bin/uic-qt4. So if you comment out the line STRING(REGEX REPLACE "uic" "uic3" ... in the CMakeLists.txt file in VTK/Examples/GUI/QT/Events it works but with a warning about a line width property.

Regards
  Andrew
(0004727)
Clinton Stimpson (developer)
2006-08-23 23:09

committed to latest cvs.

Uses new CMake 2.4.1+ feature for finding Qt4's uic3, with a fallback for CMake 2.4.0.

These CMake scripts were made before CMake 2.4 or before any linux distros included Qt4.
(0024669)
guest (viewer)
2011-01-13 17:01

Fix committed to master branch.

 Issue History
Date Modified Username Field Change
2007-08-28 11:48 Zack Galbreath Note Deleted: 0008153
2007-08-28 11:48 Zack Galbreath Assigned To Chris Brislawn =>
2007-08-28 11:48 Zack Galbreath Status @30@ => closed
2007-08-28 11:48 Zack Galbreath Resolution duplicate => fixed
2007-08-28 11:48 Zack Galbreath Summary Goodsite => Examples will not build when using QT4
2007-08-28 11:49 Zack Galbreath Project @16@ => VTK
2011-01-13 17:00 Source_changeset_attached => VTK master a2bd8391
2011-01-13 17:00 Source_changeset_attached => VTK master 020ef709
2011-01-13 17:01 guest Note Added: 0024669
2011-06-16 13:11 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2018 MantisBT Team