View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000673VTK(No Category)public2004-03-11 13:102007-08-28 14:21
ReporterJarek Sacha 
Assigned ToJeff Lee 
PriorityurgentSeverityfeatureReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000673: Runtime link error - Rendering+Java 1.5.0
DescriptionA DESCRIPTION OF THE PROBLEM :
Problem when using native libraries and Swing. Problem happens when native libraries are loaded (System.load), it does not happen when no Swing is used. Example error message:

Runtime link error - it appears that libXt got loaded before libXm,
which is not allowed.
Exception in thread "main" java.lang.InternalError: libXt loaded before libXm
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1737)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1662)
        at java.lang.Runtime.loadLibrary0(Runtime.java:817)
        at java.lang.System.loadLibrary(System.java:986)
        at vtk.vtkPanel.<clinit>(vtkPanel.java:32)
        at SimpleVTK.<init>(SimpleVTK.java:26)
        at SimpleVTK.main(SimpleVTK.java:55)



STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
Compile VTK with Java wrappers on (vtk.org). Run the cone example in step one of the tutorial (display is perfored without SWING), no problem. Run SimpleVTK, display of the same cone (same native libraries are loaded in the same order) now however the runtime error is generated.

WORKAROUND :
Preload Xm library before running JVM, for instance, rather than running application directly
$ java SimpleVTK
preload the Xm library:
$ LD_PRELOAD=/usr/X11R6/lib/libXm.so java SimpleVTK
TagsNo tags attached.
Project
Type
Attached Files

 Relationships

  Notes
(0001147)
Jarek Sacha (reporter)
2004-05-31 22:02

The intially reported problem was with Java 1.5 beta 1. I am no longer able to repeat the problem using Java 1.5 beta 2.
(0001955)
Jeff Lee (developer)
2005-01-20 11:22

since reported against beta jdk and seems to work in release, nothing to fix.

 Issue History
Date Modified Username Field Change
2007-08-28 14:21 Zack Galbreath Project @21@ => VTK
2007-08-28 14:21 Zack Galbreath Assigned To Adam Mullett => Jeff Lee
2007-08-28 14:21 Zack Galbreath Status tabled => closed
2007-08-28 14:21 Zack Galbreath Resolution fixed => won't fix
2007-08-28 14:21 Zack Galbreath Summary Goodsite => Runtime link error - Rendering+Java 1.5.0
2007-08-28 14:22 Zack Galbreath Note Deleted: 0008257
2011-06-16 13:11 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2018 MantisBT Team